Add Product

Search Results:

New Member
Posts: 1
Registered: ‎06-15-2020

Fire tv navigation ring not working

All other buttons on the remote seem to be working fine except the navigation ring and center button. Tried new batteries and pressing and holding the home button for ten seconds. Seemed to do nothing. Also tried pressing the left navigation button, menu button, and back button and also seemed to do nothing. Not sure what to do now
Posts: 1,020
Topics: 75
Kudos: 129
Solutions: 50
Registered: ‎10-19-2017

Re: Fire tv navigation ring not working

Hi there, Colleenwojo,


Welcome to our Best Buy forum community!


Although I wish you were connecting with us under happier circumstances, I'm glad that you took the time to share with us when your Fire TV remote stopped working as intended.  As someone who likes to relax by curling up on the couch and enjoying a good show, I can imagine how annoying that would be. I'd be happy to try and offer some support!


That said, we appreciate how patient you've been while waiting for a reply. We're currently handling a larger volume than normal, but are working to get to everyone as quickly as we can.


Since it's just some of the buttons not working, it seems like the issue is probably due to some of the buttons getting stuck. I recommend pushing the buttons that are not working quickly and repeatably for about one minute each. That should help get anything that could be lodged underneath un-jammed if that is what is causing the issue. Before you give that a try, take the batteries out of the remote.


If you're still having trouble with the remote after that, the next best step might be to work directly with Amazon for help. 



Elle|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!