Add Product

Search Results:

Reply
Highlighted
Visitor
Posts: 2
Registered: ‎11-06-2015

4-Port HDMI Selector Issue

I'm having an odd issue with my HDMI switcher.  I currently have a chromebox running Kodi and a Roku running Plex hooked up to my TV.  Both of these worked fine without the switcher, I just had to unplug the cables from the back of the TV and switch them around which was becoming a pain in the butt (the only new cable introduced is the one from the splitter to the tv).  Now when i switch from port 1 (the roku) to port 2 (the chromebox) the feed goes to a screen with static and a bit of random color.  Then I cycle through ports 3 and 4 back to port 1 and the Roku works fine.  In order to correct this issue I have to switch to port 2 where the chromebox is, shut the power off on the chromebox and turn it back on and then it works fine.

 

Any suggestions?

Highlighted
Visitor
Posts: 1,328
Registered: ‎08-27-2015

Re: 4-Port HDMI Selector Issue

Hello ChiveOn,

Welcome to Community@ Rocketfish™!

 

First I would try to get all the devices on the same page. Disconnect all devices (chromebox, roku, tv, Rocketfish switch) from the power for at least a minute. While they are unplugged, double check all of your HDMI connections to make sure they are all connected securely. Plug in the power to the chromebox and Roku first and give them a minute to boot. Then power on the Rocketfish for a minute, then the TV. This will hopefully get them all synced up and clear up and HDCP issues. 

Regards,
Ryan
Rocketfish™ Support

Highlighted
Visitor
Posts: 2
Registered: ‎11-06-2015

Re: 4-Port HDMI Selector Issue

I did this exactly how you asked (twice to be sure) and it has not worked.  When I finally plug in the TV and switch to the chromebox, it shows nothing on the display as though the chromebox has not been turned on.  I have to unplug it and then plug it back in to get Kodi to show up, and then the issue starts again.

 

I should mention something I left out in my original post - this issue only happens if I leave the Plex Roku on for a while.  For example, if I am on the Kodi Chrombox, switch to the Plex Roku, and then back to the Chromebox 30 seconds later there is no display issue.  If I leave it for something like 5 mins or more, then the display issue happens.

Highlighted
Visitor
Posts: 1,328
Registered: ‎08-27-2015

Re: 4-Port HDMI Selector Issue

Hello ChiveOn,


Thank you for responding!

Do you ever have issues with changing inputs to the Roku? It may be that the chromebox is just going to sleep so it isnt sending a signal out. Is there a way of potentially waking it up while it is on that input? Have you tried the chromebox in a different input on the Rocketfish selector? 

Regards,
Ryan
Rocketfish™ Support