Add Product

Search Results:

New Member
Posts: 1
Registered: ‎03-10-2018
Accepted Solution

Certificate issue errors causing rewards to go missing



I've recently had a very frustrating problem with my rewards and I'm hoping someone can help! So far, calling Best Buy Rewards and visiting customer service in store has not been helpful.




I tried to issue a rewards certificate while in a Best Buy Store. There was error, multiple times, so I gave up. The next day, I looked on my account and it says I actually have a rewards certificate on the overview page, but not when I go to the manage my rewards page. The certificate is missing — as are the associated rewards points — so it seems the certificate was only half-issued, if that makes sense.




On March 8, I had $115 worth of rewards points, with a bunch still pending. I wanted to purchase a Norelco Trimmer and the movie Coco. I issued a $55 certificate and purchased those items online, to be picked up at a nearby Best Buy store (Aiea). A few hours later, I received an email saying that the store didn't have those items in stock, so my order was cancelled and my rewards points were returned.


That same day, I decided to try to purchase those items from a different Best Buy store (Honolulu), but the store only had the trimmer (according to I issued a $45 certificate and purchased the trimmer to be picked up at the Honolulu Best Buy store.


That night, I went to the store to pick up the trimmer after receiving an email saying that my order was ready. While there, I looked around and decided that I wanted to purchase the movies Aliens Covenant and Blade Runner 2049. I tried to issue another $45 certificate (at this point, my points balance said I could issue up to $70 worth of certificates) from both the Best Buy iPhone app and the mobile website. It failed numerous times. The message was something unhelpful like, "We're sorry, we're unable to issue a reward certificate." I gave up and went home with just my trimmer, figuring that I would just try again the next day.


On March 9, I logged into my Best Buy account to try to purchase those two movies (Aliens Covenant and Blade Runner 2049) to be picked up at the Aiea store (the one nearest my home). Oddly, the account overview page said that I had a $45 certificate, so I figured the certificate I tried to issue in the store went through after all.


However, when I went in to manage my rewards, I noticed something went horribly wrong — there was no certificate to use! My rewards account balance was now $25 (so the $45 was taken out of the total $70 I had the night before). It further said "Total Certificates: $45" but just below that, in a grey box, "You don't have any rewards certificates." 


I called Best Buy at 888-237-8289 and was connected to a representative named Fernando, who had a thick accent. I had a very, very unpleasant call with Fernando, who repeatedly told me that I used my issued $45 certificate, even after I told him multiple times that I had tried to issue a second $45 certificate and this is one that is missing. Frustrated, I asked to speak with a supervisor, but Fernando refused my request and told me I'd have to go to a Best Buy store to do that. Fernando was perhaps the worst customer service representative I have ever had to deal with. 


Later that day, I visited the Aiea store and spoke with a customer service representative named Val. She tried her best to help me, and she believed me when I told her my issue and showed her the evidence on my Best Buy app. However, she couldn't rectify the issue. She spoke on the phone with someone, who told her that my points balance is no longer $70 because the original $55 certificate refund hadn't gone through yet. But when I view my Rewards History, it clearly shows a 2,750 Returned Certificate Point Adjustment (that's NOT pending); moreover, if the person on the phone was correct, I'd only have a balance of $15, not $25. 


So here I am, with $45 worth of points still missing and apparently no evidence of what happened to those points. I'm sure that if it's possible for Best Buy to recalculate my points based on my purchases, it will show that 2,250 are missing. 


I don't know how to post screenshots of the app — where it says I have and don't have a $45 certificate, as described above — but will gladly send them if there's a way to do that. PLEASE HELP. 



Posts: 10,796
Topics: 121
Kudos: 273
Blog Posts: 20
Solutions: 508
Registered: ‎01-03-2013

Re: Certificate issue errors causing rewards to go missing

Good afternoon Joseph, 

Welcome to the forum and thank you for being a My Best Buy member! It's wonderful to hear you've been doing some shopping with us lately, though I'm sorry to hear your certificate redemptions haven't been going smoothly. 


It would be incredibly frustrating to have trouble issuing a certificate, only for it to appear to have been issued based on your certificate balance, but not be available to redeem. I'm glad you reached out to our phone support and store for assistance. While our stores are generally unable to assist with My Best Buy related issues, I'm discouraged to hear of your experience with Fernando was so lackluster.


Please see that I am sending you a private message to look further into this with you. You may check your messages by signing into the forum then clicking the envelope icon in the top right corner of the page. 


Tasha|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!