Add Product

Search Results:

New Member
Posts: 4
Registered: ‎04-19-2018

Your iCloud account does not have access to modify this home

This is the message I get on my Apple iPhone XS now.   I have access to all the devices, but when I want to add a new one, the message "Your iCloud account does not have access to modify this home".   There was a blog listed as "iCloud" and that person had the same issue.   The resolution was to call Insigna directly and work through it.  I called, they told me to delete everything and start over.  Problem is, I can't delete the devices either because this message comes up for adding or deleting.

Posts: 7,326
Topics: 161
Kudos: 191
Solutions: 326
Registered: ‎11-30-2015

Re: Your iCloud account does not have access to modify this home

Greetings, rpollard,


Not being able to manage your devices using your Home app on your phone would be frustrating. Thank you for reaching out to us with the issues you’re having. We’d be happy to see if we can help point you in the correct direction.


Have you tried to contact Apple regarding the error you’re receiving? At this time, if you can’t add or delete any devices that issue may be on their end. I’d recommend trying to reboot your iPhone to see that solves the issues you’re having prior to giving Apple a call. You should be able to reboot your phone by following these directions:


Press and hold the On/Off Sleep/Wake button and the Home button at the same time for at least ten seconds, until the Apple logo appears.


Let us know, if trying to reboot your device and giving Apple a call if you’re still having an issue. We’d be happy to see what we might be able to help with on our end.



Mariah|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
New Member
Posts: 4
Registered: ‎04-19-2018

Re: Your iCloud account does not have access to modify this home

Thank you for the response.   I have been in contact with Apple to help figure out the issue.  From what we determined on the apple side, the phone was upgraded from an 8 to the 10S and the data / applications were restored from the iCloud backup.   It appears that somewhere in that restore process, the app lost the security rights to access the devices on insignia connect.   Apple said the message that pops up is coming from the insignia connect app.   It says "Your iCloud account does not have access to modify this home".   I can delete most of my devices from a home except for the wall switches which see to use homekit to get setup.   So I created a new home and was able to add all the devices including the homekit wall switches.  That is working at the moment, however, the homekit wall switches are still showing up on the old home and when I try to delete the home or the switches, I get the above message.  I have 3 homes setup and they all give me the same message.   I will re-create new homes and reset all those devices and add them to the new homes when I get to those homes and on the local network.   I hope this makes some sense.  I've tried a bunch of scenarios to work through this, but there is something with permissions that the app doesn't like.   On a side note, the wall switches that I setup from before, then re-added them to a new home also show up in the "home" app on the iphone which allows me to switch them on and off.  The outlet switches do not show up in the "home" app.