Add Product

Search Results:

New Member
Posts: 1
Registered: ‎11-19-2012

Device is unresponsive - Alexa

I have an insignia plug that worked fine before. We moved so I had to change wifi.

I have tried to delete the plug and refind it in insignia connect, then disable and enable in alexa app, 

alexa always finds the plug, but it says unresponsive and will not turn the plug on or off. 

And if I try to tell my echo to turn it on it says "sorry the lamp is not responding" 


I have tried this entire process several times with the same outcome. It works fine in the insignia connect app and will turn on and off, and the alexa skill finds it every time. But every time the same outcome "unresponsive" 

I have 2 other plugs from a different manufacturer that work fine as well.

Any help would be greatly appreciated. 

Thanks in advacne. 

Insignia Product Specialist
Posts: 15
Registered: ‎03-30-2018

Re: Device is unresponsive - Alexa


   We have a troubleshooting guide for getting your plug configured with Alexa.  You can find it here:



But I am guessing that if you switched WiFi networks, you probably need to re-onboard your device to the new WiFi network since it can't connect automatically to the new one.  There are some help videos here that are different based upon your model of plug:



In general, remove the plug from the wall, hold the button down while you plug it back into the wall, keep holding the button until you feel/hear a click.  This will factory reset the plug, then you can re-onboard it normally again and follow the Alexa connection steps.


Let us know if you have any other issues.