Add Product

Search Results:

Reply
New Member
Posts: 2
Registered: ‎08-27-2018

Subwoofer won’t work

I have an Insignia 5.1 surround sound system from 2011 and everything works but the subwoofer. It turns on with the blue ligh and it is turned on to the max but nothing comes out of it. The model is sw-51a. Anyone know what could be wrong and is it fixable? Thanks for any help.
Posts: 1,934
Topics: 34
Kudos: 314
Blog Posts: 15
Solutions: 99
Registered: ‎08-08-2017

Re: Subwoofer won’t work

Hello, Blw106, and welcome to our community.

 

The subwoofer is so crucial to the listening experience on a surround sound system. I have a few troubleshooting steps I'd like to try, but first I have a few questions for you. What input are you using to play audio? Are you experiencing this issue with just one input, or multiple? What (if any) troubleshooting steps have you tried so far?

Sam|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
New Member
Posts: 2
Registered: ‎08-27-2018

Re: Subwoofer won’t work

All inputs don’t work with the subwoofer. I turned up everything for the subwoofer. I was thinking either the cord is bad or a fuse went because it turns on blue like it’s working but nothing comes out.
Posts: 1,934
Topics: 34
Kudos: 314
Blog Posts: 15
Solutions: 99
Registered: ‎08-08-2017

Re: Subwoofer won’t work

Hello, Blw106!

 

Thank you for this update. Can you please also share the make and model number of your TV, and how it's connected to your speakers? That should be all of the information I need to try and help troubleshoot this with you.

 

Thanks,

Sam|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!