Add Product

Search Results:

Posts: 1
Registered: ‎02-26-2016

NS-CSPBTCUBE-W Doesn't control camera on iPhone 6s

When I bought this 'Bluetooth Selfie Speaker' I used an iPhone 5 and it worked great to take pictures. I upgraded to an iPhone 6s and the speaker does not control the phone's camera, but the speaker itself still works great so that rules out a bluetooth pairing issue.


So then, I tested the speaker cube on 1 android, another iPhone 5, and a different iPhone 6s. The 6s was the only one it didnt't take pictures with.



What can I do to get the camera control feature working on my iPhone 6s?




Posts: 1,264
Registered: ‎08-27-2015

Re: NS-CSPBTCUBE-W Doesn't control camera on iPhone 6s

Hello vanmart,

Welcome to Community@ Insignia™!


Since we are able to rule out a pairing issue, and since we know the camera shutter button still functions, we know that the issue is specific to the iphone 6s. In the iphone Bluetooth settings, have the phone completely forget the Insignia Bluetooth speaker, then pair the two again as if it were the first time


If you still cannot use the shutter control, there may be additional permissions that need to be given in the iphone to allow the Bluetooth device to control the camera functions. It may just be incompatible with the iphone 6s. I would recommend speaking with Apple to see if there is anything on their end that you may not have tried yet. 

Insignia™ Support

Posts: 1
Registered: ‎07-09-2016

Re: NS-CSPBTCUBE-W Doesn't control camera on iPhone 6s

I have the same issue.  Insignia should provide a better fix than say 'call Apple' 

Posts: 1
Registered: ‎10-18-2016

Re: NS-CSPBTCUBE-W Doesn't control camera on iPhone 6s

I have just discovered the same issue. It used to work with an old iPhone 4, but not with my iPhone 7 Plus on iOS 10.0.3. When paired, the software keyboard won't appear even when a text input is focused/active, which is something that happens when a Bluetooth keyboard is connected. So obviously the device is connecting and has "permission" to be an input device (permissions are a thing Android users deal with, not on iOS at all, ever, so that could never have been the problem anyway). If I select a text field and push the button on my speaker, it is acting as if it's an enter key. That probably won't make any photo app take a picture, and that is true of the 10-or-so camera apps I tried; none of them are triggered by the speaker's button/enter key press.

I was so excited to use this as a photo remote, but I guess it's just a useless piece of garbage now (since the iPhone, even going back to the iPhone 4, is both louder and has better sound quality with the built-in speaker\s).