Add Product

Search Results:

Reply
New Member
Posts: 1
Registered: ‎07-13-2021

Installation gone bad

I recently had a Sony Apple Play stereo installed at a local store in Dayton, OH.. Our installer had some issues, mostly not familiar with the products or the vehicle, he strugled with the correct wiring harnesses. The following day, I noticed the car mfg's dash plate covering the stereo and HVAC controls was not secured. In fact, it was barely installed. I also noticed a problem within the electrical system, the turn signals flash, making a rapid clicking noise (part of the mfg signaling). As much as it is annoying, it also creates a driving hazard. One day ago, the stereo began cycling through it's modes... Turner, CD, Apple Play, ect... Calling the store is not an option, as nobody will answer. Customer service did schedule an appointment two weeks out. Since this is now a driving hazard, I expect someone from Best Buy Corporarte support would like to help us resolve this issue? 

Posts: 2,331
Topics: 217
Kudos: 150
Solutions: 80
Registered: ‎07-06-2009

Re: Installation gone bad

Hello, tallbright, 

 

Welcome to our Best Buy Support community! I wish it were better circumstances that brought you to us, but I can certainly understand that you'd want to get your stereo fixed in a timely manner, given the way it has been acting. I'd be happy to see how I can help with this. 

 

Can you please send me a private message with your name, phone number, and email address? To send the message, you can use the button in my signature below. 

 

Thanks,

 

 

 

Melissa|Senior Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!