Add Product

Search Results:

Reply
New Member
Posts: 2
Registered: ‎02-27-2021
Accepted Solution

Car Stereo Install Gone Bad

[ Edited ]

Hello, In June of 2019 I purchased an Alpine carplay unit for my Lincoln Navigator. During the install, there was damage to my vehicle which required a dealer repair. That part was taken care of already. What I did not realize at the time was the the install tech installed the USB connector cord under the cental console, essentially pinching the USB cord and cutting it over time. Now, the carplay feature does not work because the cord has been cut so badly. In short, I need a new cord installed.I did purchase a new cord but would like it installed correctly. Can you help?

{removed per forum guidelines}

 

Posts: 877
Topics: 36
Kudos: 48
Solutions: 86
Registered: ‎10-19-2017

Re: Car Stereo Install Gone Bad

Hi there, Jmora82, 

 

Welcome to our community! I recently rented a vehicle and it had Apple CarPlay. I loved it, so I can understand the desire to get that fixed. 

 

To clarify here, was your installation done by a Geek Squad AutoTech? 

 

Thanks, 

Faith|Social Media Supervisor | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
New Member
Posts: 2
Registered: ‎02-27-2021

Re: Car Stereo Install Gone Bad

It was. The location was 2727 W Thunderbird.
Highlighted
Posts: 877
Topics: 36
Kudos: 48
Solutions: 86
Registered: ‎10-19-2017

Re: Car Stereo Install Gone Bad

Thanks for that additional information, Jmora82. 

 

I recommend scheduling an appointment with your local Geek Squad AutoTech here. That would be the best way to have them review what is going on and to discuss the next steps. 

 

Best, 

Faith|Social Media Supervisor | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!