Add Product

Search Results:

Reply
Highlighted
New Member
Posts: 2
Registered: ‎04-05-2020

Docking Station not working

My dual HD docking station was working fine but now when I put in a SSD and try to upload or download it works for a minute or two then unmounts giving me message about not unmounting properly etc.  Checked all cables, rebooted Mac, turn on and off, tried everything.   Any help?

Don

Highlighted
Posts: 7,184
Topics: 116
Kudos: 397
Solutions: 395
Registered: ‎12-23-2016

Re: Docking Station not working

Hi, Don,

 

Thanks for reaching out. I'm sorry to hear that your docking station sin't working right.

 

Have you tried using both ports on it? It could be an issue with the connector on one port, so please give the other port a try if you haven't.

 

Additionally, try unplugging and re-plugging the power cable and USB cable. That may also help.

 

Please let me know how that goes.

 

Sincerely, 

Kyle R|Senior Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
Highlighted
New Member
Posts: 2
Registered: ‎04-05-2020

Re: Docking Station not working

Did all that.

Highlighted
Posts: 7,184
Topics: 116
Kudos: 397
Solutions: 395
Registered: ‎12-23-2016

Re: Docking Station not working

Hi, drittner,

 

Thanks for giving that a try. 

 

Your next step will be to call Insignia support at (877) 467-4289 to discuss this with our support teams. I'm hopeful they'll be able to find a solution. 

 

Sincerely, 

Kyle R|Senior Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!