Add Product

Search Results:

Reply
Visitor
Posts: 1
Registered: ‎12-28-2009

NS-DPF9G Picture Frame stalls/freezes

Hi there, Insignia support.

 

I have a new 9" picture frame on which I loaded 30 jpeg images.  The slideshow freezes/stalls about 2/3rds of the way through the group and won't continue unless I press the "forward" button on the remote.

 

I uninstalled all the photos and did a "reset to factory settings", as I read in another thread here, then reloaded all the images.  I've tried deleting the image that it stalls on, in the hope that it's simply an image problem, but all that does is cause the slideshow to stall on another image.  At this rate, I'll be down to one photo soon...

 

If it helps in the diagnosis, I am only able to load images from my PC using the cable.  When trying to use a USB flash drive, the frame chokes and only loads about 20 of the 30 images before it freezes up and sits there endlessly on one image (with the progress bar at 100%)

 

Any suggestions before I take this back and exchange it?

 

Sincerely,

 

Ross

Highlighted
Posts: 9,123
Topics: 424
Kudos: 643
Solutions: 401
Registered: ‎09-29-2008

Re: NS-DPF9G Picture Frame stalls/freezes

Hello Ross,

Welcome to Community@Insignia™!

 

It sounds like your troubleshooting has been very thorough.  There's only one further step I would suggest and that would be to erase the internal memory.  This is the next step past deleting the files, so be sure that you have them backed up on your computer or other media!  To erase the internal memory, go to the Factory Settings menu option and set Erase Internal Memory to "Yes."  I would then recommend a reset to factory settings and powering off the frame for a few seconds before reloading your photos.  If this doesn't resolve the problem, I would recommend an exchange.

Regards,
John
Insignia™ Support

John|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!