Add Product

Search Results:

Reply
Highlighted
Visitor
Posts: 1
Registered: ‎01-12-2010

I have a problem with my NS-DPF7G digital picture frame.

It hasn't worked right since I got it. It will typically work for about five minutes or less before it displays solid black and white lines and has to be shut off before I can even access the menu. I have gotten it to run through the to the time limit twice, but both times it was malfunctioning again when I turned it back on. I have tried troubleshooting this by resetting the factory settings, using all 3 memory options to store the pictures, reconfiguring the slide-show/display options, double-checking the picture formatting, and even repositioning the frame in the room (I thought there might be interference from other electronic devices). None of this has helped. Is there anything else I can try? If not, what do I need to do to replace it?
Highlighted
Posts: 18,104
Topics: 2,979
Kudos: 655
Solutions: 490
Registered: ‎09-29-2008

Re: I have a problem with my NS-DPF7G digital picture frame.

Hello randallhentz,

Welcome to Community@Insignia™!

If you're within the retailer's return period, I would recommend pursuing an exchange.  If you're outside, service or replacement options under the factory warranty will be available through the place of purchase.

Regards,
John
Insignia™ Support
John|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
Highlighted
Visitor
Posts: 17
Registered: ‎11-24-2009

Re: I have a problem with my NS-DPF7G digital picture frame.

This sounds like an internal malfunction or connection issue.  You should get it exchanged if it is still under warranty period.