Add Product

Search Results:

Reply
Visitor
Posts: 2
Registered: ‎11-27-2009
Accepted Solution

Digital Picture Frame NS-DPF7WA-09 doesn't turn on when a SD card is inserted

Hello!

I’ve been using My Digital Picture Frame NS-DPF7WA-09 for about a year but now it just decided to not turn on when a SD card is inserted.

 

I tried to insert another SD card and format the old one using FAT32 but no luck.

 

The same SD card works fine in my digital camera and tried another SD card as well but the frame still greets me with a black screen.

 

Please note that the frame works fine when there is no SD card inserted.

 

Your assistance will be greatly appreciated!

 

Thanks!

 

Chris

Visitor
Posts: 1,174
Registered: ‎04-07-2009

Re: Digital Picture Frame NS-DPF7WA-09 doesn't turn on when a SD card is inserted

Hello Chris74,

Welcome to Community@Inisgnia™!

My first advise will be to try formatting the card using FAT32 and try restarting the frame with the empty card inserted and see if it turns on, if it does, then the issue was that the information on the card was not compatible and halted the system. You may also want to reset the picture to factory defaults to undo any changes that may have occurred. As a last option you may go to the place of purchase so a technician takes a look at it, since it may be a hardware issue.

Thank you,
Gonza
Insignia™ Support Team
Visitor
Posts: 2
Registered: ‎11-27-2009

Re: Digital Picture Frame NS-DPF7WA-09 doesn't turn on when a SD card is inserted

Hi Gonza, 

 

I tried to turn the Digital Frame on with a formatted the SD card using FAT32 when the problem started but it didn’t work.

 

I followed your advice of resetting the Frame settings to its default values and the problem persisted. 

 

Before giving up, I formatted the SD card with my digital camera and the Digital Frame came back to life! 

 

Thanks for your help!

 

Cheers, 

 

Chris