Add Product

Search Results:

Reply
Highlighted
Visitor
Posts: 1
Registered: ‎04-09-2018

Wi-Fi Smart Plug. Wi-Fi setup issues

I've got the smart plug in the wall. The green light is blinking. I am connected to my Wi-Fi but every time I hit Continue it disconnects my phone from Wi-Fi then tells me I have to be on Wi-Fi to proceed...
Posts: 5,343
Topics: 85
Kudos: 254
Solutions: 248
Registered: ‎11-30-2015

Re: Wi-Fi Smart Plug. Wi-Fi setup issues

Greetings Stepperot,

 

Welcome to our community. I’m sorry to hear that you’re having some issues pairing your Smart Plug. I’d be delighted to see how we might be able to help you moving forward.

 

Can you please share the exact error you’re getting? Have you tried the troubleshooting steps noted below?

 

1- Reset the plug by pressing and holding the power button on the front for 30 seconds to a minute, the plug will make a clicking noise when it has been reset. On plugs without power meter, the plug needs to be off; then, press the power button and continue holding it when it turns back on.

2- Log out of the Best Buy account and log back in. If you have has your account associated on other phones, make sure all accounts on all phones are logged out.

3- Uninstall and Re-install the Insignia CONNECT application.

4- Make sure that the router is configured at a 2.4 GHz band or has the capability of dual bandwidth.

5- Please be as close as possible to plug during paring.

6- Ensure there is a strong Wi-Fi signal where the plug is being setup.

7- Is your router’s security set on WPA-PSK? Sometimes changing the password sometimes works to get the plug installed.

8- Try different power outlets.

 

I look forward to you reply to learn more about your setup issue if those troubleshooting steps do not work.

 

Kindly,

 

Mariah

Insignia™ Support

Mariah|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
Visitor
Posts: 1
Registered: ‎04-14-2018

Re: Wi-Fi Smart Plug. Wi-Fi setup issues

Stepperot I'm having the same issue with my light switches. (been having various issues over the last 5 months with these darn things). Customer service is only going to run you through exact same 8 steps everytime. Going today to replace these with WeMo switches.