Add Product

Search Results:

Reply
New Member
Posts: 2
Registered: ‎04-17-2017

Complaint

I took my 2003 Ford Mustang in to have the stereo deck installed. The first red flag that I noticed was that it was done in just 20 minutes. Then, when we turned on the system there was no bass. I asked the installer if he hooked up everything and he said "Oh Yeah, everything is hooked up. I then went home. After trying about 2 hours to try to get the deck to sound half way decent, I went online to see how to hook the system up. I then took the stereo out of my car and sure enough, the sub-woofer was not installed. The installer didn't even leave me that part of the harness to connect myself( BTW, I paid for that harness)  I then went to Best Buy in Delafield, WI to complain and get my harness. Best Buy's answer to my issue was to have me come back (about 60 miles round trip out of my way) have the installer take the radio out of my car and refund my money... I told them that they could check my car, I already had most of the system disconnected and I needed the harness to correct their mistake. I also said that's unacceptable; Furthermore, Even though I had the receipt showing I paid for the harness they still had the audacity to charge me again for another harness. To top it off, it's the wrong harness... I just ordered the correct harness on Amazon. 

Geek Squad Agent
Posts: 3,251
Registered: ‎03-20-2012

Re: Complaint

TJ1970,

Thank you for taking the time to join and write with us on the Community Forums, but I do wish it was under better circumstances.  Most vehicles can be completed in under a half hours time frame with a standard car stereo, and we do warranty our workmanship for the lifetime of the vehicle at any Best Buy across the nation with an installation bay.  It is truly upsetting to hear that your subwoofer was not connected even after having to pay for a new harness that should have connected this feature. 

 

With that said, there are quite a few different harnesses for that vehicle year, make, and model since there are a few trim levels that come with that Mustang. If you have any premium sound like the "shaker 500" or the "shaker 1000" this will require a specific harness that will have the additional speaker plug for the remote turn on wires and also the subwoofer RCA's. If this was a feature that came with your vehicle our MECP certified Autotech should have sold you the harness, and also connected the harness to allow these OEM features to continue to play with the new deck installed.  I do want to make sure that you are talking about a stock setup, and not an aftermarket subwoofer combo that didn't come with the vehicle from the factory, is that correct?

 

I realize that driving 60 miles is less than ideal, but our techs can do warranty work on your vehicle to get this connection running again, and usually they carry it in stock, but please make sure when you call in to have them verify the part is on hand for your scheduled time slot for the warranty fix.  One last thing that I want to clarify is that the second harness that you were charged, was that an actual harness that had a model number 70-5***, beause if it was the premium sound there could be a wired transistor that would drop the voltage from 12V to 6V called the AX-CAM6V.  The description would show another harness, but this really is not a harness it is a voltage divider that will make sure that you do not have speaker pop when you turn the vehicle on and off.

 

Your best bet to have this resolved would be to head back to the installation bay, or one closest to you to have this resolved.  Although I cannot see the vehicle myself, it is a very common vehicle that I have worked on plenty over my years as an installer.  Please accept my sinceriest apologies for the troubles that this has caused, and do not hesitate to let me know if there is anything else I could be of further assistance with. Thank you again for the time that you took to provide us with your very valuable feedback!  

I am a CAR Geek Squad Autotech, but the views that I post are my own and not that of Best Buy.
***Know that I am not able to issue official responses and that my posts are only here to help before an official response is offered by a Best Buy Social Media Specialist***
Was the question answered click solution and kudos the post?!
Posts: 4,168
Topics: 208
Kudos: 171
Blog Posts: 11
Solutions: 198
Registered: ‎01-21-2014

Re: Complaint

Hello TJ1970,

 

It’s incredibly disappointing to hear your recent car service with us didn’t go quite according to plan! Customers place a lot of trust in us when leaving their vehicle with our Geek Squad Auto Tech team, so it’s understandable why you’d be concerned if the new stereo you just have installed with us isn’t working as anticipated, especially if you felt the necessary time wasn’t taken to ensure things were properly set up. I’m not sure what ultimately happened (or didn’t happen), but I apologize for any frustration this must be undoubtedly causing.

 

Like our super user and, autotech796, mentioned, the best way to resolve this would be by visiting the store that performed the installation service. Although not ideal if they are 60 miles away from you, we would need to review the work completed in order to see what might have happened. With that said, please feel free to ask to speak with the Geek Squad manager at the time of your visit. They should be able to address any questions or concerns you may have, as well as work with you to figure out our next steps from here.

 

If you have any further questions for me though, please don’t hesitate to reply here on this post. I’ll be happy to help in any way possible.

 

Sincerely,

Alexandra|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!
New Member
Posts: 2
Registered: ‎04-17-2017

Re: Complaint

[ Edited ]

I have the standard mack 460 system, I may have mistated when I said subwoofer but it is the 2nd harness that the installer left out that, if not installed, the system has no "bass". As I said in my complaint, I even asked the intaller is everything was connected and he stated "oh yeah" as wel as telling me that he's worked on 1000s of mustangs. He SHOULD HAVE never forgot this piece. At the very least, show have wondered what the smaller harness was that was in the package. I have installed radios in the past, I don't like doing it, that's why I paid someone to install this one and I know that if you have extra parts in a bag usually something was not hooked up. I  figured out what was missing from looking on YOUTUBE! See attached video that you may want to show to the installer: 

 

(removed per forum guidelines)

 

I had the stereo basicly out of the vehicle and offered to show the manager what was left out. They just said to bring the vehicle back have it taken out and get a refund... That is unacceptable because I would have to reinstall it, come back to the store, Have them uninstall it, just so I could take it and install it myself??? It doesn't make sense.

 

BTW, why was i charged again for the same harness twice????

 

I don't want anything from Best Buy, I quess you must need my $100 that bad but it will be the last of my money you will ever get. The majority of your products are not necessities. I'll just as soon order the same products with my Amazon Prime account and get it in two days.

Highlighted
Posts: 4,168
Topics: 208
Kudos: 171
Blog Posts: 11
Solutions: 198
Registered: ‎01-21-2014

Re: Complaint

Hello again, TJ1970,

 

I realize this situation is far from ideal; however, we would need the chance to review the completed work in order to discuss possible outcomes other than a possible refund, as well as fully discuss what occurred to ensure you were not incorrectly charged for unnecessary parts.

 

I understand if this is not an option for you, but please feel free to reach out to your Best Buy store should you change your mind in the near future.

 

Thank you,

Alexandra|Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!