Add Product

Search Results:

Posts: 1
Registered: ‎01-30-2017

Insignia Flex 10.1: cannot connect to PC using USB

I have an Insignia Flex 10.1" (model NS-P10A7100), Android version 6.0.1.   I am attempting to connect this tablet via the USB connection to a Windows PC.   However, when I connect the machines, I get no reaction from the PC side.   The tablet shows that it is charging over the USB cable, so at least some sort of connection is being made.


In reading other messages on this forum, I have seen suggestions that I need to activat the USB connection.   However, I do not see a setting for doing so.   Under Settings -> Device -> Storage & USB, there are no options dealing with USB.   I see "Total Space", "Firmware", "Apps", "Images", "Videos", "Audio", "Other", "Cached data", and "Explore".    Selecting "Explore" leads me into some sort of file manager, but with no way to move away from the tablet itself.


From the PC side, I have tried connection with Windows 7, 8, and 10 laptops.   Some of them on first connection attempt to install a driver, but the driver installation fails.   But even those machines no longer react to any attempt to attach the tablet.



Posts: 21
Registered: ‎12-26-2016

Re: Insignia Flex 10.1: cannot connect to PC using USB

When you plug it in to the computer, watch the status bar up at the top.  It should show some sort of an notification showing "USB connnected, select options".


You may have to swipe down on the status bar to see the notification.  Select it, and you should have options for 1) Charging only  2) Transfer files  3) Use as MTP device, etc..


Choose "Transfer Files" and then your computer should recognize it.  Let it install whatever drivers it needs, then you should be able to see your device as either a Generic USB Device or possibly the device's name.  It also may show up under "Other Devices" rather than as a drive.  Click on it and it should show the tablet's internal storage drive.

Posts: 1
Registered: ‎01-07-2018

Re: Insignia Flex 10.1: cannot connect to PC using USB

I am having same issue. I did lower the notifications bar and have "no" notifications. It did work the first time I transferred some photos but hasn't worked since. Just bought tablet yesterday (Insignia NS-P10A8100)