Add Product

Search Results:

Reply
New Member
Posts: 1
Registered: ‎02-20-2017

Canon EOS Rebel T5 Flash Not Opening

Hello All. I have a Canon EOS Rebel T5. The flash on it use to work. But now all of sudden. The flash will not open. When i hit the flash button this error is displayed: "This function is not selectable in the current shooting mode". Now I've tried every shooting mode on this thing and i still get the same error. Any suggestions would be appreciated. Thanks!

Highlighted
Posts: 7,367
Topics: 80
Kudos: 260
Blog Posts: 43
Solutions: 312
Registered: ‎09-29-2008

Re: Canon EOS Rebel T5 Flash Not Opening

Hey darkmanrob85,

 

Sorry to hear this. My first suggestion would be to Clear all Settings on the camera, and after you do that clear all custom functions. This should set the camera back to factory settings, and often resolves errors like this. Let me know if this does not work for you.

 

Thanks,

Allan|Senior Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!